Apr 18

[原]基于mysql 5.0的Discuz从2.5SP1升级到4.1的方法 晴

linuxing , 11:47 , 其他 » 杂七杂八 , 评论(0) , 引用(0) , 阅读(14284) , Via 本站原创 | |
 因为原有的论坛有些问题,而且Discuz已经正式发布了4.1版本。决定对论坛进行升级,以完善功能。在升级期间,发现官方提供的升级程序和mysql 5.0有点不适合。现把改动过的步骤列出来:
系统环境:OpenBSD 3.8
数据库:mysql 5.0
1、获得升级程序
升级程序分开两部分,一是获得Discuz 4.1程序包;二是数据库升级包。
可以从官方论坛获得:
Discuz 4.1安装程序
DISCUZ2.5(sp1版也可以使用) 到 4.0升级程序
2、升级Discuz 4.1程序包
升级的方法很简单,只要把Discuz 4.1解压后,把upload目录覆盖原来Discuz 2.5SP1的根目录。然后修改templates、forumdata、attachments、customavatars等目录的权限为777即可。
# cd /usr/local/www/data/discuz/upload/upload/
# cp -R ./ /usr/local/www/data/discuz/
# cd /usr/local/www/data/discuz/
# chmod -R 777 ./templates/ ./forumdata/ ./attachments/ ./customavatars/

3、编辑数据库连接文件
# vi config.inc.php

根据你连接数据库的信息进行修改。包括连接数据库的服务器,用户名、密码,使用的数据库等。
若您在安装的时候改了表前缀名,请同样的修改$tablepre变量。
另外,mysql 5.0数据库与旧3.0版本有字符表的区别,需要修改$dbcharset为你使用的默认字符表,如utf8。
4、升级数据库
首先,拷贝数据库升级程序包到论坛的根目录下:
# cd /usr/local/www/data/upload/
# unzip upgrade25to4.zip
# cd /usr/local/www/data/discuz/
# cp /usr/local/www/data/upload/upgrade25to4.php ./

下面就是本次升级的重点。
因为mysql一些特性的升级,所以官方提供的升级包不能直接用于mysql 5.0上,需要修改一下:
# sed -e "s/default ''//g" upgrade25to4.php > upgrade25to4.php.new
# rm upgrade25to4.php
# mv upgrade25to4.php.new upgrade25to4.php

最后,就可以用下面的链接进行升级了:(请把域名修改为你自己的IP或域名)
引用
http://域名/upgrade25to4.php

程序一共有15步,会自动进行,不用手工干预。
点击在新窗口中浏览此图片
点击在新窗口中浏览此图片
※成功升级后,请删除upgrade25to4.php文件。
※若你觉得修改麻烦的话,下面文件是已经修改过的:点击下载
5、从4.0升级到4.1
上面的数据库程序已经完成了2.5SP1升级到4.0的步骤。下面进行4.0升级到4.1的过程:
先拷贝4.1程序包中utilities目录下的upgrade6.php文件到论坛的根目录下:
# cp /usr/local/www/data/upload/utilities/upgrade6.php ./

用下面的链接升级即可:
引用
http://域名/upgrade6.php

程序一共有8步,会自动进行,不用手工干预。
点击在新窗口中浏览此图片
点击在新窗口中浏览此图片
※成功升级后,请删除upgrade6.php文件。
6、更新缓存
一切都成功后,进入论坛的管理面板,重新更新一次缓存,以及统计信息和目录权限等,以保证论坛信息正常。
到此,升级的工作就完成了。剩下的就是检查论坛是否正常,以及熟悉新功能咯!
Tags: ,
发表评论
表情
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
emotemotemotemotemot
打开HTML
打开UBB
打开表情
隐藏
记住我
昵称   密码   游客无需密码
网址   电邮   [注册]